
Getting Photoshop Layers into Flash
The first time you try to import a layered Photoshop file (.PSD) into a Flash (.FLA) document, you 

might be surprised at the results. Flash MX 2004, and all previous versions, does not actually know 

what to do with .PSD file. The only thing it can import is the flattened composite version of the 

file, and that only happens if QuickTime is installed on your machine. Fortunately, there are sev-

eral workarounds you can use to get all those layers in Photoshop into Flash. Five possible work-

arounds are summarized below.

Photoshop to PNG

Each layer in the PSD needs to be exported 

from Photoshop as a separate PNG file 

to preserve transparency. Each PNG is 

imported into Flash, converted to a symbol 

and placed on a separate layer. You can 

automate this process with the File > Export 

> Layers as Files command in ImageReady 

CS and higher.

ImageReady to SWF

Use the File > Export > Layers as Files com-

mand in ImageReady CS or higher. Each 

layer is exported as a separate SWF. Then 

import the SWFs into Flash where each SWF 

will end up on its own layer. Slices, image 

maps, and rollovers are lost. 

PSD2FLA

This is an export plug-in for Photoshop that 

exports multi-layered PSD files as an FLA 

file with all layers intact, ready to animate. 

Position and Layer names from Photoshop 

are retained. The plug-in works with 

Photoshop versions 4 and higher. (www.

medialab.com/psd2fla)

notes

Photoshop & Flash: Optimizing Pixels and Workflow
With Michael Ninness

Executive Director, Lynda.com

Michael Ninness paid his way through the Graphic Design BFA program at the University of Washington by teaching 

digital imaging tools and techniques to professional designers and photographers. Since then, he has worked in the 

graphics software industry as a product manager and user interface designer of products for creative professionals at 

Extensis, Microsoft and Adobe. In early 2005, Michael returned to his training roots and joined the team at Lynda.com, an 

award-winning education provider of self-paced online video training, CDs, books and events for designers, developers, 

instructors, students and hobbyists.



notes

with Michael Ninness

Photoshop CS2 & Flash 8 Integration

Fireworks

Another alternative is to open your PSD files 

in Fireworks. Fireworks retains most of the 

original Photoshop file, including keeping 

text editable. Flash can import a Fireworks 

file directly, and it maintains an Edit Original 

link to the Fireworks PNG file.

Illustrator

Another alternative is to open your PSD files 

in Illustrator 10 or higher, which will convert 

PSD layers to AI layers. You can then export 

the AI file as a single SWF where each AI 

layer becomes a frame, or you can export 

each layer as a separate SWF file and import 

them into Flash.
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Creating a Bitmap Rollover Button in Flash
I want to create a button from one of my small image thumbnails. I want the thumbnail to be 

semi-transparent in the Normal state of the button, and to be 100% opaque in the Over state. This 

gets a little complicated, because in Flash, you can’t change the opacity of a bitmap directly -- you 

have to change the opacity of the Symbol (container) that the bitmap is in. What? Read on for the 

steps:

Step One: Select the bitmap on the Stage that you want to turn into a button.

Step Two: Choose Modify > Convert to Symbol, (or press the F8 key). Choose Movie Clip and give 

the Symbol a name. What you’ve done here is to wrap the bitmap in a container that can be ani-

mated or have its Alpha (Opacity) value changed.

Step Three: Now, we are going to place the resulting Movie Clip into a Button Symbol so that we 

can create different button states for it. Press the F8 key again, and this time choose Button as the 

Symbol behavior and give it a descriptive name.

Step Four: Double-Click on the Button Symbol you just created on the Stage. This will open the 

Button and reveal button states in the Timeline. By default, there will only be a keyframe set for 

the Up (a.k.a Normal) state. Click on the frame for the Over state, and duplicate the contents of the 

Up state into the Over state by pressing the F6 key. (This is the keyboard shortcut for inserting a 

new Keyframe.)

Step Five: Click on the keyframe for the Up state, then click on the thumbnail image on the stage 

(this is the Movie Clip Symbol inside the Button Symbol). In the Properties palette, change None 

to Alpha from the Color pop-up menu, and change the Alpha value to 25%.

Step Six: Click on the Scene 1 link at the top of the Timeline to exit the Button Symbol and return 

back to the Stage. Go ahead and test your movie by pressing Cmd + Return and test your button 

in the resulting window. You should see it pop into 100% opacity when you roll over it, and return 

back to 25% opacity when you roll off of it.
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Loading External JPEG, PNG or GIF Files
One effective way to control the file size of an exported SWF file is to keep your large bitmap files 

separate from the main SWF, and only load them in when the user needs to see them. You can 

accomplish this by using one of the default Behaviors in Flash.

Step One: You need to create a place-holder Movie Clip. In other words, you need a container 

that the image(s) you are going to load can go into. In this example, I created a rectangle with no 

fill and a stroke color that is the same color as the Stage. I selected the rectangle and converted 

into a Movie Clip Symbol. One thing to note is that I’ve made the rectangle the same size as the 

images I plan on loading into it. This means the image will come in at its actual size and be placed 

exactly in the same position as the place-holder container. Matching the size of the images is not 

a requirement — if you are adventurous, you can change what happens to the image when it gets 

loaded into the place-holder container through ActionScript.

Step Two: After you’ve converted the rectangle into a Symbol, it is very important that you give 

the Instance of the Symbol that is on the Stage an Instance Name. Any object that you want to 

control through ActionScript must have a unique Instance Name. Select the Symbol on the Stage, 

and then name it in the Instance field of the Properties panel. In this example, I’ve simply named it 

“container”, without the quotes.

Step Three: Select the Symbol that you want to use as your “trig-

ger” object. That is, the object you will click on in the exported 

SWF file to trigger the loading of the external image file that you 

want to pull-in. In the Behaviors panel, click on the plus (+) icon 

and choose Movieclip > Load Graphic.

Step Four: In the Load Graphic dialog box, enter in the URL or 

path to the external image file you wish to load. Choose the movie clip 

into which to load the JPEG into — in this case, you would choose the 

“container” movie clip.

Alternative Approach: The Load Graphic Behavior is essentially add-

ing the necessary ActionScript code to the trigger object for you. A 

cleaner approach (i.e. less code) is to select the trigger object, open the 

Actions panel (F9), and type in the ActionScript code below. You would 

replace “container” with the name of the place-holder movie clip you are using, and “picture03.

jpg” with the URL to the image you want to load.

on (release) {

 container.loadMovie(“picture03.jpg”);

}
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Tips for Working with Pixel-Based Images in Flash

Don’t resize images in Flash
Always bring your images into Flash at the actual size (pixel dimensions) you intend to use 

them at. Anytime you scale an image on the Flash state, it will be resampled and interpolated. 

Photoshop does a much better job than Flash when it comes to resampling. The only exception to 

this rule is when you are animating the scale of an image. Of course, in that scenario, it is always 

best to bring the image in from Photoshop at it’s largest size in the desired animation.

Resolution does not matter
Many web designers out there still believe that their web graphics must have a resolution of 

72dpi. Turns out, resolution is only relevant when you PRINT a graphic. When working with a 

graphic that will be displayed on a monitor of any kind, you only need to worry about pixel 

dimensions, not resolution. Don’t believe me? Try this: Open the New Document dialog in 

Photoshop and change the dimensions to 800 x 600 pixels. Then, change the resolution from 72 

dpi to 600dpi. See how the file size does not change at all?

Use Bicubic Sharper
Most images you intend on using in your 

Flash project will need to be downs-

ampled with Image Size command in 

Photoshop. This dialog box is split into 

to parts; an “upstairs” for web designers 

and a “downstairs” for print designers. 

Notice what is not in the upstairs area? 

That’s right, there is no Resolution field! 

If you can’t select the width or height 

fields in the upstairs area, it’s because 

the Resample Image checkbox at the 

bottom of the dialog box is turned off. 

Turn it back on, and you’ll now be using 

the Image Size command to resample an image instead of resizing it. As a reminder, Resample 

changes the number of pixels in an image (and the file size). Resize means you are simply chang-

ing the print dimensions and resolution without changing the actual number of pixels in the 

image. The default “resampling algorithm” in Photoshop is Bicubic. For better results, use Bicubic 

Sharper when downsampling an image. Bicubic tends to make images get a bit soft whereas 

Bicubic Sharper preserves more of the original detail. 

Stay on the pixel grid
Always use whole pixel values for the X and Y position of your images as sometimes you can 

end up with weird “pixel-shifting” in the exported SWF file if your images are not aligned to the 

pixel grid in Flash. You can force Flash to help you stick to the grid by choosing View > Snapping 

> Snap to Pixels. Choose this menu command before importing images to the Stage as it is not 

retroactive. That is, if an image is not on the pixel grid before you choose the Snap to Pixels com-

mand, Flash does not automatically shift the image back to the grid. You’ll need to select the 

image and manually change the X and Y values in the Properties panel. Once this command 

is turned on however, you can use the arrow keys on your keyboard to nudge images on the 

stage in exactly one pixel increments and know that they will stay aligned to the pixel grid.
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Controlling Bitmap Optimization in Flash

Publish Settings
By default, when you import a PNG file into Flash, 

it will not export out in the resulting SWF file as a 

PNG — rather, it will be exported as a JPEG instead. 

Because JPEG is a lossy-compression file format, the 

image quality will go down. The default JPEG quality 

setting used for ALL imported PNGs can be changed 

by choosing File > Publish Settings, clicking on the 

Flash tab and changing the JPEG Quality slider. See 

below if you want to control the optimization settings 

for each bitmap independently.

Import JPEGs for best results
The JPEG optimization engine in Flash, to put it polite-

ly, isn’t that great. You will get much better and pre-

dictable results by saving your images as JPEGs from 

Photoshop instead. While that does mean more work 

for you, the good news here is that a JPEG imported 

into Flash goes out in the resulting SWF file exactly 

as it came in. That is, an imported JPEG does not get 

recompressed when you publish to a SWF.

Per-object compression
You can always override how Flash optimizes import-

ed bitmaps on a per-object basis. To do so, you simply 

double-click on the image you want to change in the 

Library panel to open the Bitmap Properties dialog 

box. If you select a JPEG file, you can force it to recom-

press at a lower quality setting, and thus reduce its file 

size further. If you select a PNG file, you can force it to 

export out as a PNG so the quality does not change, 

or you can choose a JPEG quality other than the 

default setting specified in the Flash tab of the Publish 

Settings dialog box.
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Channel-Based Optimization in Photoshop
Have you ever wished that you could control the optimization settings of two different areas in a 

single image independently? For example, in the image used here, I care more about the couple’s 

faces than I do about the background. It would be cool if I could keep the quality very high 

around their faces, but reduce the file size of the background much smaller. Here’s how you do it:

Step One (Create a New Channel): Choose Window > Channels. Click the New Channel button 

at the bottom of the Channels palette. Click on the eye for the RGB channel so you can see your 

image and the new alpha channel at the same time.

Step Two (Paint a Mask): Press the B key to select the Brush tool. With a soft-edged brush, paint 

with white on the areas you care about the most. In this example, I painted around their faces. 

When you are done, click on the name of the RGB channel, and turn of the eye for the Alpha 1 

channel.

Step Three (Save for Web): Choose File > Save for Web (Cmd+Option+Shift+S) [Ctrl+Alt+Shift+S] 

and choose JPEG for the file format.

Step Four (Modify Quality Setting): Click on the tiny button to the right of the Quality field to 

open the Modify Quality Setting dialog box. Choose Alpha 1 from the Channel pop-up menu. The 

black slider sets the quality value for the areas defined in the black portion of the mask and the 

white slider sets the quality value for the white areas of the mask. You can now control the optimi-

zation quality for each area separately. When satisfied, click the OK button and save the file.

Excerpted from the Photoshop CS2 & Flash 8 Integration video training title available in the  

lynda.com Online Training Library™. 

Copyright: ©2006 Michael Ninness and Lynda.com

Register for a FREE one-week pass to the Online Training Library at http://www.lynda.com/freepass/michael

michael@lynda.com 
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 If you use Photoshop on a Macintosh to create your Web graphics, you’ve probably noticed that the graphics appear a 
lot darker when viewed on a Windows machine. And you may have also noticed that your image colors look different 
in Flash than they do in Photoshop. 

 Well, it’s true that Macintosh and Windows displays do look different, with Windows displays being darker than their 
Macintosh counterparts. That’s because the two platforms use different gamma values. While there isn’t anything you 
can do about this gamma issue, you can change how you work in Photoshop to at least preview what a graphic created 
on a Mac but viewed on a PC will look like. 
 Let’s look at the two settings in Photoshop that affect how a graphic for the Web can be previewed—Color Settings 
and Proof Setup/Proof Colors—then we’ll show you how to compare Mac and Windows previews. 

	 					Color	SettingS
             First, go under the Edit menu 

and choose Color Settings to 
bring up this dialog.

STEP ONE: Look under Working Spaces 
at the RGB setting. The default working 
space for RGB images in Photoshop is 
sRGB. This is the same color space that 
most display manufacturers adhere to 
as well. Viewing images in the sRGB 
space while working in Photoshop is  
as close as you can get to predicting 
what they’ll look like on a webpage  
or in a Flash (SWF) file.
 If you’ve changed the RGB working 
space to something else for a different out-
put destination, you should change it back Default settings

web col rs?Can I get

All signs point to yes.

Preview	CroSS-Platform	web	graPhiCS	aCCurately	without	the	uSe	of	a	magiC	8	ball

consistent

Reprinted by permission of the National Association of Photoshop Professionals (www.photoshopuser.com)

http://www.photoshopuser.com
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to sRGB while working on Web graphics. 
 Note: You might consider setting 
up Actions to switch between working 
spaces if you use this feature often. 
[NAPP members may download the 
actions mentioned in this tutorial from 
www.photoshopuser.com/members/
magcenter.2006.php.]

STEP TWO: Under Color Management 
Policies, click on the arrow to the right 
of RGB and select Convert to Working 
RGB from the drop-down menu. If you 
completed Step One above, then this 
will convert all the images you open 
into the sRGB working space. 
 This is also very important in a Photo-
shop-to-Flash workflow as Flash doesn’t 
support any embedded profiles other 
than sRGB. In other words, if you’re 
working in the Adobe RGB color space 
and then choose to embed the Adobe 
RGB Color Profile when you save the 
file, when you place the image in Flash, 
the Adobe RGB profile is ignored and 
Flash essentially displays the image as if 
it had been saved with an sRGB profile 
instead. That’s what’s causing the colors 
to look like they’ve changed. If you force 
your images into an sRGB color space in 
Photoshop, they’ll look the same when 
you place them in Flash later. 

Proof	ColorS/	
Proof	SetuP
This is the other “gotcha”  
area that can skew how  
images are displayed onscreen. 

STEP ONE: (You’ll need to have an 
image open for this step.) From the 
View menu, choose Proof Colors to 
select it (shortcut is Command-Y [PC: 
Control-Y]) and a checkmark appears 
beside it. This will change how images 
are displayed onscreen and it’s basically 
an onscreen soft proof of the specified 
output destination. You might notice 
that the image looks dramatically differ-
ent after turning on Proof Colors. Don’t 
worry. We’ll make it look right in the 
next steps. 

STEP TWO: Now look in the View>Proof 
Setup menu and notice that by default, 

Before After Proof Colors turned on
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Reprinted by permission of the National Association of Photoshop Professionals (www.photoshopuser.com)

http://www.photoshopuser.com
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the Proof Setup is set to Working CMYK 
(it has a checkmark beside it in the list). 

STEP THREE: As you might have guessed, 
Working CMYK isn’t the right Proof Setup 
choice for a Web workflow. Instead, 
choose Windows RGB from the View> 
Proof Setup menu. Yes, that’s correct 
even if you’re creating graphics on a 
Mac—actually, especially if you’re creat-
ing graphics on a Mac—because the 
vast majority of the intended viewing 
audience will most likely be viewing 
your images on a Windows machine. 

Tip: You can change the default for 
Proof Setup in Photoshop with no doc-
ument open. Just choose View>Proof 
Setup>Windows RGB.

 

ComParing	maC	and	
windowS	PreviewS

Proof Settings is a command that 
can be set differently for each open 

document. Here’s a way to preview 
how your image will look on both a Mac 
and Windows monitor at the same time: 

STEP ONE: Duplicate the current docu-
ment (Image>Duplicate). Then choose 
View>Proof Setup>Macintosh RGB. This 
will show you how your image will look 
on a Mac monitor. 

STEP TWO: Click on your original docu- 
ment and choose View>Proof Setup> 
Windows RGB to preview how your 
image will look on a Windows monitor.

STEP THREE: To get real fancy, you 
could also tile the windows (Window>  
Arrange>Tile Vertically) and match  
their Zoom and Location (Window> 
Arrange>Match Zoom and Location). 
 And, of course, you might have 
guessed that you can also set up an 
Action to do this for you as well. 

Note: If you’re working in ImageReady, 
the equivalent command for the Photo- 
shop Proof Setup/Proof Colors is View> 
Preview>Standard Windows Color. n Mac RGB (left) and Windows RGB (right)

With Windows RGB Proof Setup
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